Tag Archives: Windows Vista

Toshiba Satellite L300 + SSD – refresh attempt :)

I wasted most of my last weekend trying to do something with extremely sluggish Toshiba Satellite L300 laptop with Windows Vista. After some years of being in use by my father this laptop become so slow that it exceed tolerance limits even such undemanding user as he is 🙂 As a new and really good laptop was not something within available budget for this particular case, I’ve decided to replace HDD with SSD for best performance gain possible (adding RAM was not an option as this model can’t handle more that 2 GB which were already installed, I found it difficult to believe into this limitation, especially these days, when we can have 64 GB of RAM in desktops 🙂 ).

I ended up buying 240 Gb OCZ Arc 100 to replace built in 160 Gb Toshiba HDD.

OCZ_SSD_Toshiba_HDD

This procedure was easy, unlike further wipe and load procedures. Carelessly I started my attempt to put Windows 10 TP onto this antique device – it took 2 attempts and some pondering on why Windows 10 install freezes on “Getting Ready” phase somewhere in the end… I tried to google this and 2 most common suggestions for the similar issues were that windows fails to load/find compatible driver (not sure what’s the difficulty to surface an error/warning for this) and splendid suggestion “I know this is not very good answer but just wait for couple of hours, it may work out, it did for me”. In the end I decided that I wasted enough time waiting, and end up with installing x64 Windows Vista as this laptop was shipped with this OS. Though before doing that I decided to remove another possible reason of poor performance – dust in cooling system:

Toshiba_L300_Dust

It required almost complete disassembling of laptop, though it seems that it was necessary thing to do as air which the system blow out from the inside before cleaning was way too hot.

Toshiba_L300_motherboard

I have not had good Vista SP2 ISO file with all the updates and it took me almost whole day while Vista tried to download all post RTM updates 🙂 At some point I decided that downloading SP2 and installing it would speed up the process – so did I, only to find out that I have to download and install SP1 first. After all service packs were installed it took extra 5 hours to got all the subsequent updates.

OCZ_SSD_Installed

In generally I would say that putting SSD improved responsiveness of this laptop but not to extend I expected – i think mainly because other components become bottleneck and also due to the fact that Vista doesn’t support TRIM as at the time when Vista was released SSD weren’t mass market product. In case of Windows TRIM stated to be supported with release of Windows 7/Server 2008 R2 for SATA drives and starting from Windows 8 and onward Windows TRIM supports PCI Express SSDs based on NVMe (Non-Volatile Memory), and the unmap command which is a full analog of the trim command from Serial ATA for devices that use the SCSI driver stack. It seems that missing TRIM may lead to SSD performance degradation overtime unless you don’t have and use some third party software which takes care about this (e.g. Samsung provides sofware which performs garbage collection for their SSDs), but also Vista not as quick starting from SSD as Windows 7 which I believe has other SSD related optimizations. But anyway before installing SSD this system used to take 2 minutes to start (and something like up to 5-6 minutes to the moment when you can actually start using it, i.e. antivirus and other stuff finally started and your desktop become responsive) and something like 15-30 second to start IE, after switch to SSD these delays decreased and system is more pleasant to work with. Alas, there is no that blazing fast speed which you may see when you put SSD into a bit more powerful system with more RAM and newer OS optimized for SSD, where you can reach something very close to impressive 15 seconds from power off to fully operational desktop, but in the end it was not the aim of this attempt 🙂

Please follow and like us: