Installing Exchange 2016

I’ve finally found some time to install Exchange 2016 in my test environment. This thing has been on my to do list for a long time, and recently Nicolas Prigent wrote a blog post at StarWind blog on exactly this subject – Installing Exchange Server 2016 on Windows Server 2016, leaving me no excuses for not completing task from my to do list anymore 🙂

So essentially instructions provided in the abovementioned blog post were sufficient for me for getting Exchange Server 2016 up and running in my test environments. Installation process itself is a bit lengthy and before that you have to take care of prerequisites as well as prepare your AD DS schema. With these preliminary parts I had couple of issues which I will mention below.

First of all you have to have the following update for Windows Server 2016 – KB3206632 which is available for download in Microsoft Update Catalog. When I installed this update on my Hyper-V VM with Windows Server 2016 I had an issue on reboot stage – system sort of went into applying updates and restart but then stuck with empty blue background. After waiting for about 8 hours (I just left box running during the night) I just powered off VM and switched it on again – update was applied successfully after this.

Next part is AD DS schema modifications you need to make before installing Exchange by issuing the following commands one after another (strictly in order specified):

cd d:
#Step 1 Preparing AD DS Schema
.\setup /PrepareSchema /IAcceptExchanfeServerLicenseTerms
#Step 2 Preparing AD DS
.\setup /PrepareAD /OrganizationName:"Conundrum" /IAcceptExchanfeServerLicenseTerms
#Step 3 Prepare Domain
#In case you have multiple domains replace PrepareDomain with PrepareAllDomains
.\setup /PrepareDomain /IAcceptExchanfeServerLicenseTerms

I run into issues with steps 1 and 2. Step 1 failed with on Extending Active Directory schema with the following error:

There was an error while running ‘ldifde.exe’ to import the schema file ‘C:\Windows\Temp\ExchangeSetup\Setup\Data\PostWindows2003_schema0.ldf’ The error code is: 8224.

To solve this I just attached installation ISO to one of my DCs and run it there – operation completed without errors.

Next issue happened on step 2:

An Active Directory 0x51 occurred when trying to check the suitability of server. Error: ‘ActiveDirectory response: The LDAP server is unavailable.’

In this case re-running the same command from DC didn’t helped and what actually helped is moving schema master role from one DC to another. If you are a bit rusty on how to do this – see this blog post.

So thanks to Nicolas’ post I now have Exchange 2016 in my test environment, and I already reconfigured my K2 farm (yes I run 4.7 + Feb 2017 CU) to enable Exchange Server integration:

Please follow and like us:

3 thoughts on “Installing Exchange 2016

  1. Kevin Walton

    I had the same “There was an error while running ‘ldifde.exe’ to import the schema file ” error when installing Exchange 2016 in a test environment, in the test environment I had only one of our DC’s, the live environment we had three but for the sake of testing I just wanted to use the single DC with all the FSMO roles on it within the testing environment. The problem is caused by the single DC not being able to replicate to the other DC’s, I found the easiest way to fix it was to go to the single DC I was using and Seizing the “Schema Master” role (using ntdsutil), although it was already there in the first place this reaffirms it in the single DC. I was then able to run the Exchange 2016 install to completion (which in itself preps the schema in the domain).

    Reply
  2. Ian Bennett

    What happens if the powershell does not accept the IAcceptExchangeServerLicenseTerms parameter?
    What causes that to occur if running the PS commands from the new Windows 2016 Exchange server

    Reply
    1. Mikhail Post author

      Are you sure it is not accepting this parameter? Which error message you get? Problems I mentioned in this blog post may happen if you don’t have AD DS RSAT components installed on your machine and this this is why doing this on DC solved them.

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *