K2 Connect 4.6.9 – System key not being displayed

I am unable to judge about SAP’s software with my little direct exposure to their technology stack, but it should be cool based on what I heard and looking at their price tags and consultant salaries. Probably because of the same reasons many companies end up not using it, as after some initial considerations and conversations decision makers back out from the idea once they see price tag for support contract, and most importantly initial roll out price – their SAP implementation project either going to be moved to the next FY or buried forever. But those who deployed it with such a high CAPEX and OPEX try to use it fully and will require all the other applications integrate with it. Also where SAP is present it is often plays a role of primary/master LOB data store. Not only K2 software supports integration with SAP by means of K2 Connect for SAP, but it allows you to integrate numerous other systems with your SAP implementation playing a role of enterprise hub through which line of business (LOB) data flowing in, out and around an enterprise’s network.

Anyway, today I spent some time doing test installation of K2 connect 4.6.9, and run into little issue which worth mentioning. Namely I was not able to enter K2 connect license as it didn’t show me system key (see screenshot below).

K2 Connect 4.6.9 - No machine key\n\nThat’s a problem – you can’t use it without entering license key, and you can not request license key without machine key :)\n

So my first idea was that LOCAL SYSTEM account which is suggested by default by K2 connect installation wizard for K2 Connect service is not something appropriate for running this service 🙂 But in fact I was wrong and all following 4 options are entirely appropriate for account running K2 Connect service:

\n\n

    \n

  1. System Account
  2. \n

  3. The installation Account, if granted the correct rights
  4. \n

  5. The K2 Service Account, or
  6. \n

  7. A dedicated account for the K2 connect Service

This is described in K2 Connect for SAP User Guide in Installation Prerequisites section. Any of aforementioned accounts can be used to run K2 Connect Service and permission requirement necessary for in include the following:

\nMust be part of the Local Administrators group.\nTwo folders are written to by the server and require write permissions:\nC:Program FilesK2 connectConfiguration\nC:Program FilesK2 connectService\n

And in terms of K2 Connect Database rights K2 connect service account should have db_owner rights on it. And when those rights not in place you see this issue with missing system key. By the way there is even no need to reopen that window above/restart K2 connect administration app to fix this. Just grant your K2 Connect Service account db_owner rights. By the way if you revoke the db_owner rights afterwards system key stays cached and you see it even without any access to DB (though you won’t be able to start K2 Connect service) unless you reinstall K2 Connect app once again – then you will see missing system key if your K2 connect service account does not have db_owner righs on K2 Connect DB.

What strange here is that we are doing installation in line with official documentation requirements (i.e. installation account has DbOwner and Sysadmin rights on SQL)  and I don’t understand why db_owner rights can be granted for designated service account during setup automagically 🙂 I also don’t remember any warnings from K2 Connect Setup about the fact that I have to grant those. Probably there is a potential for feature request 🙂

Please follow and like us:

Leave a Reply

Your email address will not be published. Required fields are marked *